iOS 10.0-10.2 JB Status

This is just a friendly reminder that iOS 10.0 – 10.2 (iPhone 6S and lower; for iPhone7/7+ read below) can now be jailbroken with a BETA jailbreak for 64-Bit devices. With that in mind if you care about being Jailbroken please get to the best firmware ASAP. Currently 10.2 is still being signed (https://ipsw.me/#!/version)

If you have any additional questions feel free to reach out to me on twitter @unlimapps

What you need to know:

iPhone 7/7+: Stay on 10.1.1 or lower if you can. If you can’t then get to 10.2 and stay there.

ANY other 64-Bit device and you want 10.2 features and a JB then please get to 10.2 while the window is still open to be able to Jailbreak.

For Info on how to downgrade: http://www.ibtimes.sg/how-downgrade-ios-10-2-1-ios-10-2-iphone-ipad-ipod-touch-6852

Please keep in mind that this JB is in BETA and currently ONLY supports the following devices with more to come:

  • iPhone SE
  • iPhone 6s
  • iPhone 6s+
  • iPad Pro

Supported iOS Versions for Above Devices:

  • 10.0.x
  • 10.1.x
  • 10.2

***The most important thing you can do at this point is get to the correct firmware as outlined above. More devices will be supported in the coming days/weeks. If you would like to try the JB and you have a supported device links are below.***

The official page for the JB is: https://yalu.qwertyoruiop.com/

For info on how to install the latest JB Windows: http://www.iclarified.com/58881/how-to-jailbreak-your-iphone-on-ios-102-using-yalu-and-cydia-impactor-windows 

For info on how to install the latest JB Mac: http://www.iclarified.com/58878/how-to-jailbreak-your-iphone-on-ios-102-using-yalu-and-cydia-impactor-mac

11 thoughts on “iOS 10.0-10.2 JB Status

  1. I am confused, It says The jailbreak is good for all devices that are below 6s and lower. But then it says it only works for these devices.. iPhone SE, iPhone 6s, iPhone 6s+, iPad Pro. So what is it?? Does it work on the iPhone 6+? Maybe it shouldnt say ALL DEVICES that are below 6s, unless that is true, if it is, then why put ONLY these devices iPhone SE, iPhone 6s, iPhone 6s+, iPad Pro. Help!?!?!? Which is it??? Will it work on my iPhone 6+

    Liked by 1 person

  2. I’ ve got a iPhone 6+ running jailbroken iOS 9.3.3.3.

    Are you recommending that I upgrade to un-jailbroken iOS 10.2 and wait until the JB for 10.2 is released?

    Thsnks…

    Like

    1. Definitely worth the update, the JB works well as far as I can tel, haven’t had it very long, but my 9.3.3 was falling apart, very unstable, from all the installing/uninstalling of apps/tweaks/themeing etc.. So this was a blessing to get this at the time, I was sick of the constant reboots on the old 9.3.3 jailbreak.. I actually have an iPhone 6+ and an iPhone 7+, so hoping eventually he gets it working on the 7+ so I can sell the 6+.. Anyways, THANKS Unlimapps, been using your work for a long time now and always respect what you do for the community

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s